Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Wireless daemon for Linux" |
| 2 | HOMEPAGE = "https://iwd.wiki.kernel.org/" |
| 3 | LICENSE = "LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" |
| 5 | |
| 6 | DEPENDS = "ell" |
| 7 | |
| 8 | SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 9 | SRCREV = "aa3dc1b95348dea177e9d8c2c3063b29e20fe2e9" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit autotools manpages pkgconfig python3native systemd |
| 13 | |
| 14 | PACKAGECONFIG ??= " \ |
| 15 | client \ |
| 16 | monitor \ |
| 17 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 18 | " |
| 19 | PACKAGECONFIG[client] = "--enable-client,--disable-client,readline" |
| 20 | PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor" |
| 21 | PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native" |
| 22 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" |
| 23 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" |
| 24 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" |
| 25 | |
| 26 | EXTRA_OECONF = "--enable-external-ell" |
| 27 | |
| 28 | SYSTEMD_SERVICE_${PN} = " \ |
| 29 | iwd.service \ |
| 30 | ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \ |
| 31 | " |
| 32 | |
| 33 | do_configure_prepend() { |
| 34 | install -d ${S}/build-aux |
| 35 | } |
| 36 | |
| 37 | do_install_append() { |
| 38 | # If client and monitor are disabled, bindir is empty, causing a QA error |
| 39 | rmdir --ignore-fail-on-non-empty ${D}/${bindir} |
| 40 | } |
| 41 | |
| 42 | FILES_${PN} += " \ |
| 43 | ${datadir}/dbus-1 \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 44 | ${nonarch_libdir}/modules-load.d \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 45 | ${systemd_unitdir}/network \ |
| 46 | " |
| 47 | |
| 48 | RDEPENDS_${PN} = "dbus" |
| 49 | |
| 50 | RRECOMMENDS_${PN} = "\ |
| 51 | kernel-module-pkcs7-message \ |
| 52 | kernel-module-pkcs8-key-parser \ |
| 53 | kernel-module-x509-key-parser \ |
| 54 | " |