Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \ |
| 6 | file://build-Allow-CC-and-prefix-to-be-overriden.patch \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 7 | file://Use-cross-cpp-in-incdefs.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | " |
| 9 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 10 | SRC_URI[md5sum] = "1318805702eb6d59f9f247e1dd5ce12a" |
| 11 | SRC_URI[sha256sum] = "d74ceca722c75bfff53c633425f926dd48eb04f4a089451b855155c016d15785" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 13 | EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} EXTRA_CFLAGS='${CFLAGS}'" |
| 14 | |
| 15 | export KBUILD_OUTPUT="${RECIPE_SYSROOT}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | do_install () { |
| 18 | install -d ${D}/${bindir} |
| 19 | install -p ${S}/ptp4l ${D}/${bindir} |
| 20 | install -p ${S}/pmc ${D}/${bindir} |
| 21 | install -p ${S}/phc2sys ${D}/${bindir} |
| 22 | install -p ${S}/hwstamp_ctl ${D}/${bindir} |
| 23 | } |