James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=dd0607f896f392c8b7d0290a676efc24" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 6 | |
Andrew Geissler | dce5cf9 | 2020-05-17 11:54:15 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \ |
Andrew Geissler | dce5cf9 | 2020-05-17 11:54:15 -0500 | [diff] [blame] | 8 | " |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 9 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 10 | SRCREV = "db78ac1d7716f56fc9f1b030b715f872f93964e4" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 17 | |
| 18 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 19 | |
| 20 | RDEPENDS_${PN}-dev = "" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 23 | |
| 24 | # other packages commonly reference the file directly as "json.hpp" |
| 25 | # create symlink to allow this usage |
| 26 | do_install_append() { |
| 27 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 28 | } |