Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Small Footprint CIM Broker" |
| 2 | DESCRIPTION = "\ |
| 3 | Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \ |
| 4 | Operations over HTTP protocol. It is robust, with low resource consumption \ |
| 5 | and therefore specifically suited for embedded and resource constrained \ |
| 6 | environments. sfcb supports providers written against the Common \ |
| 7 | Manageability Programming Interface (CMPI)." |
| 8 | HOMEPAGE = "http://www.sblim.org" |
| 9 | SECTION = "Applications/System" |
| 10 | LICENSE = "EPL-1.0" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261" |
| 12 | DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" |
| 13 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 14 | inherit features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | REQUIRED_DISTRO_FEATURES = "pam" |
| 16 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | file://sfcb.service \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ |
| 20 | file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \ |
| 21 | file://sblim-sfcb-1.3.16-maxMsgLen.patch \ |
| 22 | file://sblim-sfcb-1.4.5-service.patch \ |
| 23 | file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \ |
| 24 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ |
| 25 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \ |
| 27 | file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | file://sblim-sfcb-1.4.9-fix-sfcbinst2mof.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 29 | file://0001-Avoid-variable-definition-in-header-files.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 31 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 32 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" |
| 33 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
| 34 | |
| 35 | inherit autotools |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | inherit systemd |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 37 | |
| 38 | SYSTEMD_PACKAGES = "${PN}" |
| 39 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" |
| 40 | SYSTEMD_AUTO_ENABLE = "enable" |
| 41 | |
| 42 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
| 43 | |
| 44 | EXTRA_OECONF = '--enable-debug \ |
| 45 | --enable-ssl \ |
| 46 | --enable-pam \ |
| 47 | --enable-ipv6 \ |
| 48 | CFLAGS="${CFLAGS} -D_GNU_SOURCE"' |
| 49 | |
| 50 | # make all with -j option is unsafe. |
| 51 | PARALLEL_MAKE = "" |
| 52 | |
| 53 | INSANE_SKIP_${PN} = "dev-so" |
| 54 | CONFIG_SITE = "${WORKDIR}/config-site.${P}" |
| 55 | |
| 56 | do_install() { |
| 57 | cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg |
| 58 | |
| 59 | oe_runmake DESTDIR=${D} install |
| 60 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 61 | install -d ${D}${systemd_unitdir}/system |
| 62 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 63 | |
| 64 | install -d ${D}${sysconfdir}/init.d |
| 65 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb |
| 66 | sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 67 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 68 | rm -rf ${D}${libdir}/sfcb/*.la |
| 69 | } |
| 70 | |
| 71 | pkg_postinst_${PN} () { |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 72 | $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX} |
| 73 | } |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 74 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 75 | pkg_postinst_ontarget_${PN} () { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 76 | ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb |
| 77 | ${bindir}/sfcbrepos -f |
| 78 | } |
| 79 | |
| 80 | FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb" |
| 81 | FILES_${PN}-dbg += "${libdir}/sfcb/.debug" |
| 82 | |
| 83 | RDEPENDS_${PN} = "perl bash" |