Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame^] | 1 | SUMMARY = "This is the io_uring library, liburing." |
| 2 | DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \ |
| 3 | instances, and also a simplified interface for applications that don't need \ |
| 4 | (or want) to deal with the full kernel side implementation." |
| 5 | HOMEPAGE = "https://github.com/axboe/liburing" |
| 6 | BUGTRACKER = "https://github.com/axboe/liburing/issues" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "LGPLv2.1 | MIT" |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9" |
| 11 | |
| 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https" |
| 13 | SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | DEPENDS_append_libc-musl = " libucontext" |
| 17 | XCFLAGS = "-pthread" |
| 18 | XCFLAGS_append_libc-musl = " -lucontext" |
| 19 | |
| 20 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
| 21 | |
| 22 | do_install () { |
| 23 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 24 | } |