blob: 9ac23cda4f73d2df4c8ea16048c42c88cfdbee04 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
7LDSHARED += "-pthread"
8
Andrew Geisslerd688a012020-09-18 13:36:00 -05009SRC_URI[md5sum] = "aa91e4974981b29e99b863c54034c361"
10SRC_URI[sha256sum] = "26409a473cc6278e4c90f782cd5968ebad04d3911ed1c402fc86908c17633e08"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
Brad Bishop316dfdd2018-06-25 12:45:53 -040012SRC_URI += " \
13 file://run-ptest \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050014 file://h-test.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17inherit pypi setuptools3
18
19DEPENDS += " \
20 ${PYTHON_PN}-cffi \
21 ${PYTHON_PN}-cffi-native \
22 ${PYTHON_PN}-asn1crypto \
23 ${PYTHON_PN}-six \
24"
25
26RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-cffi \
28 ${PYTHON_PN}-idna \
29 ${PYTHON_PN}-asn1crypto \
30 ${PYTHON_PN}-setuptools \
31 ${PYTHON_PN}-six \
32"
33
34RDEPENDS_${PN}_class-target += " \
35 ${PYTHON_PN}-cffi \
36 ${PYTHON_PN}-idna \
37 ${PYTHON_PN}-numbers \
38 ${PYTHON_PN}-asn1crypto \
39 ${PYTHON_PN}-setuptools \
40 ${PYTHON_PN}-six \
41 ${PYTHON_PN}-threading \
42"
43
44RDEPENDS_${PN}-ptest += " \
45 ${PN} \
46 ${PYTHON_PN}-cryptography-vectors \
47 ${PYTHON_PN}-iso8601 \
48 ${PYTHON_PN}-pretend \
49 ${PYTHON_PN}-pytest \
50 ${PYTHON_PN}-pytz \
51"
52
53inherit ptest
54
55do_install_ptest() {
56 install -d ${D}${PTEST_PATH}/tests
57 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
58 install -d ${D}${PTEST_PATH}/tests/hazmat
59 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
60}
61
62FILES_${PN}-dbg += " \
63 ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
64"
65
66BBCLASSEXTEND = "native nativesdk"