blob: da731989dae13ac87a0d0cf5713ad1e38c4a4a3f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1"
Brad Bishope42b3e32020-01-15 22:08:42 -050017LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerd688a012020-09-18 13:36:00 -050019SRC_URI[md5sum] = "0f171e365e294554f8e7624ccf511067"
20SRC_URI[sha256sum] = "66d8ec82d30f2b95d8b4bd51659429066c2879d3f46292561f5fdbc7fed10f3d"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
Andrew Geisslerd221e032020-07-10 16:13:21 -050022inherit pypi setuptools3 update-alternatives
Brad Bishope42b3e32020-01-15 22:08:42 -050023
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024DEPENDS += " \
25 ${PYTHON_PN}-ply-native \
26 ${PYTHON_PN}-pyyaml-native \
27 ${PYTHON_PN}-six-native \
28"
29
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030RDEPENDS_${PN}_class-target += "\
31 ${PYTHON_PN}-datetime \
32 ${PYTHON_PN}-io \
33 ${PYTHON_PN}-netclient \
34 ${PYTHON_PN}-ply \
35 ${PYTHON_PN}-pyyaml \
36 ${PYTHON_PN}-six \
37 ${PYTHON_PN}-stringold \
38 ${PYTHON_PN}-threading \
39 ${PYTHON_PN}-unixadmin \
40 ${PYTHON_PN}-xml \
41"
42
Andrew Geisslerd688a012020-09-18 13:36:00 -050043ALTERNATIVE_${PN} = "mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050044ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050045
46ALTERNATIVE_PRIORITY = "60"
47
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048BBCLASSEXTEND = "native"