Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "MCE test suite" |
| 5 | |
| 6 | DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \ |
| 7 | testing the Linux RAS related features, including CPU/Memory error \ |
| 8 | containment and recovery, ACPI/APEI support etc." |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 12 | |
| 13 | SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \ |
| 14 | file://makefile-remove-ldflags.patch \ |
| 15 | " |
| 16 | SRCREV = "74bffd8b0aa27051aeaa1983a7b23975ca8d8726" |
| 17 | PV = "20171030+git${SRCPV}" |
| 18 | |
| 19 | RDEPENDS_${PN} = "mcelog mce-inject dialog bash" |
| 20 | |
| 21 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |
| 22 | |
| 23 | S ="${WORKDIR}/git" |
| 24 | |
| 25 | do_install_append(){ |
| 26 | install -d ${D}/opt/mce-test |
| 27 | cp -rf ${S}/* ${D}/opt/mce-test/ |
| 28 | } |
| 29 | |
| 30 | FILES_${PN} += "/opt" |