Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require rsync.inc |
| 2 | |
| 3 | |
| 4 | SRC_URI += "file://acinclude.m4 \ |
| 5 | file://0001-Complain-if-an-inc-recursive-path-is-not-right-for-i.patch \ |
| 6 | file://rsync.git-eac858085.patch \ |
| 7 | " |
| 8 | |
| 9 | SRC_URI[md5sum] = "43bd6676f0b404326eee2d63be3cdcfe" |
| 10 | SRC_URI[sha256sum] = "7de4364fcf5fe42f3bdb514417f1c40d10bbca896abe7e7f2c581c6ea08a2621" |
| 11 | |
| 12 | PACKAGECONFIG ??= "acl attr" |
| 13 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 14 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
| 15 | |
| 16 | # rsync 3.0 uses configure.sh instead of configure, and |
| 17 | # makefile checks the existence of configure.sh |
| 18 | do_configure_prepend () { |
| 19 | rm -f ${S}/configure ${S}/configure.sh |
| 20 | cp -f ${WORKDIR}/acinclude.m4 ${S}/ |
| 21 | |
| 22 | # By default, if crosscompiling, rsync disables a number of |
| 23 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 24 | export rsync_cv_can_hardlink_special=yes |
| 25 | export rsync_cv_can_hardlink_symlink=yes |
| 26 | } |
| 27 | |
| 28 | do_configure_append () { |
| 29 | cp -f ${S}/configure ${S}/configure.sh |
| 30 | } |