Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \ |
| 2 | safe memory reclamation mechanisms and non-blocking data structures \ |
| 3 | designed to aid in the design and implementation of high performance \ |
| 4 | concurrent systems." |
| 5 | |
| 6 | LICENSE = "BSD & Apache-2.0" |
| 7 | HOMEPAGE = "http://concurrencykit.org" |
| 8 | SECTION = "base" |
| 9 | |
| 10 | PV = "0.5.1+git${SRCPV}" |
| 11 | SRCREV = "f97d3da5c375ac2fc5a9173cdd36cb828915a2e1" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 13 | SRC_URI = "git://github.com/concurrencykit/ck.git \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | file://cross.patch \ |
| 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*" |
| 20 | |
| 21 | inherit autotools-brokensep |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | PLAT:powerpc64 = "ppc64" |
| 24 | PLAT:powerpc64le = "ppc64" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | PLAT ?= "${HOST_ARCH}" |
| 26 | |
| 27 | do_configure () { |
| 28 | export PLATFORM=${PLAT} |
| 29 | export COMPILER='gcc' |
| 30 | ${S}/configure \ |
| 31 | --prefix=${prefix} \ |
| 32 | --includedir=${includedir} \ |
| 33 | --libdir=${libdir} |
| 34 | } |
| 35 | |
| 36 | do_compile () { |
| 37 | oe_runmake |
| 38 | } |
| 39 | |
| 40 | do_install () { |
| 41 | oe_runmake 'DESTDIR=${D}' install |
| 42 | } |