blob: 38918249431e19285e9eadc2a272c6525eb8d0a7 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001HOMEPAGE = "http://www.newrelic.com"
2SUMMARY = "New Relic Python Agent"
3DESCRIPTION = "\
4 Python agent for the New Relic web application performance monitoring \
5 service. Check the release notes for what has changed in this version. \
6 "
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic"
9LIC_FILES_CHKSUM = "file://newrelic/LICENSE;md5=0f6cc160a8ed6759faa408a30b6ac978"
10
11PR = "r0"
12SRCNAME = "newrelic"
13
14SRC_URI = "https://pypi.python.org/packages/source/n/newrelic/${SRCNAME}-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "f8c9bf996d040a11847d14682b290eff"
17SRC_URI[sha256sum] = "aa8869413c21aff441a77582df1e0fdc0f67342760eb7560d33ed3bbed7edf7b"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools
22
23FILES_${PN}-dbg += "\
24 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \
25 ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/packages/*/.debug/ \
26 "