Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame^] | 1 | HOMEPAGE = "http://www.newrelic.com" |
| 2 | SUMMARY = "New Relic Python Agent" |
| 3 | DESCRIPTION = "\ |
| 4 | Python agent for the New Relic web application performance monitoring \ |
| 5 | service. Check the release notes for what has changed in this version. \ |
| 6 | " |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD-3-Clause & MIT & Python-2.0 & BSD-2-Clause & NewRelic" |
| 9 | LIC_FILES_CHKSUM = "file://newrelic/LICENSE;md5=0f6cc160a8ed6759faa408a30b6ac978" |
| 10 | |
| 11 | PR = "r0" |
| 12 | SRCNAME = "newrelic" |
| 13 | |
| 14 | SRC_URI = "https://pypi.python.org/packages/source/n/newrelic/${SRCNAME}-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "f8c9bf996d040a11847d14682b290eff" |
| 17 | SRC_URI[sha256sum] = "aa8869413c21aff441a77582df1e0fdc0f67342760eb7560d33ed3bbed7edf7b" |
| 18 | |
| 19 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 20 | |
| 21 | inherit setuptools |
| 22 | |
| 23 | FILES_${PN}-dbg += "\ |
| 24 | ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/*/.debug \ |
| 25 | ${PYTHON_SITEPACKAGES_DIR}/newrelic-${PV}/newrelic/packages/*/.debug/ \ |
| 26 | " |