Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "Helper tool used when compiling" |
| 2 | DESCRIPTION = "pkg-config is a helper tool used when compiling applications and libraries. It helps determined \ |
| 3 | the correct compiler/link options. It is also language-agnostic." |
| 4 | HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/" |
| 5 | BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=pkg-config" |
| 6 | SECTION = "console/utils" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 8 | LICENSE = "GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | DEPENDS = "glib-2.0" |
| 12 | DEPENDS_class-native = "" |
| 13 | DEPENDS_class-nativesdk = "" |
| 14 | |
| 15 | SRCREV = "5914edfe9604abfedd220103cbac382fc4d268bb" |
| 16 | PV = "0.29+git${SRCPV}" |
| 17 | |
| 18 | SRC_URI = "git://anongit.freedesktop.org/pkg-config \ |
| 19 | file://pkg-config-native.in \ |
| 20 | file://fix-glib-configure-libtool-usage.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | " |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools |
| 26 | |
| 27 | EXTRA_OECONF = "--without-internal-glib" |
| 28 | EXTRA_OECONF_class-native = "--with-internal-glib" |
| 29 | EXTRA_OECONF_class-nativesdk = "--with-internal-glib" |
| 30 | |
| 31 | acpaths = "-I ." |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
| 35 | # Set an empty dev package to ensure the base PN package gets |
| 36 | # the pkg.m4 macros, pkgconfig does not deliver any other -dev |
| 37 | # files. |
| 38 | FILES_${PN}-dev = "" |
| 39 | FILES_${PN} += "${datadir}/aclocal/pkg.m4" |
| 40 | |
| 41 | # When using the RPM generated automatic package dependencies, some packages |
| 42 | # will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by |
| 43 | # specifying an appropriate provide. |
| 44 | RPROVIDES_${PN} += "pkgconfig(pkg-config)" |
| 45 | |
| 46 | # Install a pkg-config-native wrapper that will use the native sysroot instead |
| 47 | # of the MACHINE sysroot, for using pkg-config when building native tools. |
| 48 | do_install_append_class-native () { |
| 49 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ |
| 50 | -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ |
| 51 | < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native |
| 52 | install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native |
| 53 | } |