Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 5 | |
| 6 | inherit autotools pkgconfig gnomebase distutils-base gobject-introspection |
| 7 | |
| 8 | DEPENDS += "python glib-2.0 gnome-common" |
| 9 | |
| 10 | SRCNAME="pygobject" |
| 11 | SRC_URI = " \ |
| 12 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 13 | file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "0a956f3e785e23b0f136832f2e57a862" |
| 17 | SRC_URI[sha256sum] = "2a3cad1517916b74e131e6002c3824361aee0671ffb0d55ded119477fc1c2c5f" |
| 18 | |
| 19 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |
| 22 | |
| 23 | EXTRA_OECONF = "--disable-cairo --with-python=python2.7" |
| 24 | |
| 25 | RDEPENDS_${PN} += "python-setuptools python-importlib" |