Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "PBZIP2 is a parallel implementation of bzip2" |
| 2 | DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \ |
| 3 | file compressor that uses pthreads and achieves near-linear speedup on SMP \ |
| 4 | machines. The output of this version is fully compatible with bzip2 v1.0.2 or \ |
| 5 | newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)." |
| 6 | HOMEPAGE = "http://compression.ca/pbzip2/" |
| 7 | SECTION = "console/utils" |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=398b8832c6f840cfebd20ab2be6a3743" |
| 10 | |
| 11 | DEPENDS = "bzip2" |
| 12 | DEPENDS_append_class-native = " bzip2-replacement-native" |
| 13 | |
| 14 | SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6" |
| 17 | SRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6" |
| 18 | |
| 19 | UPSTREAM_CHECK_URI = "http://compression.ca/pbzip2/" |
| 20 | |
| 21 | EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'" |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | install -m 0755 pbzip2 ${D}${bindir}/ |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |