Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | # note that we allow for us to use data later than our code version |
| 2 | # |
| 3 | SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect" |
| 4 | LICENSE = "PD & BSD & BSD-3-Clause" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2" |
| 7 | |
| 8 | SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \ |
| 9 | http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata" |
| 10 | |
| 11 | SRC_URI[tzcode.md5sum] = "ffb82ab0b588138759902b4627a6a80d" |
| 12 | SRC_URI[tzcode.sha256sum] = "344b1bd486935bca2b7baa47db3b99b32211c45f31ec0d1ead8bacd103c5a416" |
| 13 | SRC_URI[tzdata.md5sum] = "0330ccd16140d3b6438a18dae9b34b93" |
| 14 | SRC_URI[tzdata.sha256sum] = "8700d981e6f2007ac037dabb5d2b12f390e8629bbc30e564bc21cf0c069a2d48" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | |
| 18 | inherit native |
| 19 | |
| 20 | do_install () { |
| 21 | install -d ${D}${bindir}/ |
| 22 | install -m 755 zic ${D}${bindir}/ |
| 23 | install -m 755 zdump ${D}${bindir}/ |
| 24 | install -m 755 tzselect ${D}${bindir}/ |
| 25 | } |