Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "cross-platform C library to defer selection of GL API and of window system" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \ |
| 4 | file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf" |
| 5 | |
| 6 | SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \ |
| 7 | file://0001-third_party-threads-Use-PTHREAD_MUTEX_RECURSIVE-by-d.patch \ |
| 8 | " |
| 9 | SRC_URI[md5sum] = "c669c91bf2f7e13a5d781c3dbb30fd8c" |
| 10 | SRC_URI[sha256sum] = "d2c096cf654bf0061323a4b9231a1ef5b749a1e5c7c5bfe067e964219c2a851c" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html" |
| 13 | |
| 14 | inherit cmake distro_features_check lib_package |
| 15 | |
| 16 | # This should be overridden per-machine to reflect the capabilities of the GL |
| 17 | # stack. |
| 18 | PACKAGECONFIG ??= "glx" |
| 19 | |
| 20 | # libx11 requires x11 in DISTRO_FEATURES. |
| 21 | REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}" |
| 22 | |
| 23 | # I say virtual/libgl, actually wants gl.pc |
| 24 | PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/libgl libx11" |
| 25 | |
| 26 | # I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland |
| 27 | # DISTRO_FEATURE. |
| 28 | PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,-Dwaffle_has_wayland=0,virtual/libgl wayland" |
| 29 | |
| 30 | # I say virtual/libgl, actually wants gbm.pc egl.pc |
| 31 | PACKAGECONFIG[gbm] = "-Dwaffle_has_gbm=1,-Dwaffle_has_gbm=0,virtual/libgl udev" |
| 32 | |
| 33 | # I say virtual/libgl, actually wants egl.pc |
| 34 | PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,-Dwaffle_has_x11_egl=0,virtual/libgl libxcb" |
| 35 | |
| 36 | FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake \ |
| 37 | ${libdir}/cmake/Waffle/" |