Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP and WebDAV client library with a C interface" |
| 2 | HOMEPAGE = "http://www.webdav.org/neon/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ |
| 6 | file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "http://www.webdav.org/${BPN}/${BPN}-${PV}.tar.gz \ |
| 9 | file://pkgconfig.patch \ |
| 10 | file://gnutls_4.3_fixup.patch" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 11 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "231adebe5c2f78fded3e3df6e958878e" |
| 13 | SRC_URI[sha256sum] = "00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd" |
| 14 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | inherit autotools binconfig-disabled lib_package pkgconfig |
| 16 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 17 | # Enable gnutls or openssl, not both |
| 18 | PACKAGECONFIG ?= "expat gnutls libproxy webdav zlib" |
| 19 | PACKAGECONFIG_class-native = "expat gnutls webdav zlib" |
| 20 | |
| 21 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat" |
| 22 | PACKAGECONFIG[gnutls] = "--with-ssl=gnutls,,gnutls" |
| 23 | PACKAGECONFIG[gssapi] = "--with-gssapi,--without-gssapi,krb5" |
| 24 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy" |
| 25 | PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2" |
| 26 | PACKAGECONFIG[openssl] = "--with-ssl=openssl,,openssl" |
| 27 | PACKAGECONFIG[webdav] = "--enable-webdav,--disable-webdav," |
| 28 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib" |
| 29 | |
| 30 | EXTRA_OECONF += "--enable-shared" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | |
| 32 | do_compile_append() { |
| 33 | oe_runmake -C test |
| 34 | } |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 35 | |
| 36 | BINCONFIG = "${bindir}/neon-config" |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |