Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require pseudo.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ |
| 5 | file://fallback-passwd \ |
| 6 | file://fallback-group \ |
| 7 | " |
| 8 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "6e4b59a346d08d4a29133c335ea12052" |
| 10 | SRC_URI[sha256sum] = "f33ff84da328f943155f22cfd49030ef4ad85ad35fc2d9419a203521b65c384c" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" |
| 13 | |
| 14 | do_install_append_class-native () { |
| 15 | install -d ${D}${sysconfdir} |
| 16 | # The fallback files should never be modified |
| 17 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd |
| 18 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group |
| 19 | } |