Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | LICENSE = "GPLv2" |
| 2 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 3 | file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 4 | file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4" |
| 5 | require remake.inc |
| 6 | |
| 7 | SRC_URI += "file://version-remake.texi.patch \ |
| 8 | " |
| 9 | SRCREV = "cf54641d50a0165bb17622b3e9770f426ccbc561" |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | DEPENDS += "readline guile" |
| 13 | # Need to add "gettext-native" dependency to remake-native. |
| 14 | # By default only "gettext-minimal-native" is added |
| 15 | # when inherit gettext. |
| 16 | DEPENDS_class-native += "gettext-native" |
| 17 | PROVIDES += "make" |
| 18 | |
| 19 | do_configure_prepend() { |
| 20 | # remove the default LINGUAS since we are not going to generate languages |
| 21 | rm ${S}/po/LINGUAS |
| 22 | touch ${S}/po/LINGUAS |
| 23 | # create config.rpath which required by configure.ac |
| 24 | ( cd ${S}; autopoint || touch config.rpath ) |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |