blob: e6174821ff8a07bb81513a33f401a78a4ed282be [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Ultralightweight JSON parser in ANSI C"
2AUTHOR = "Dave Gamble"
3HOMEPAGE = "https://github.com/DaveGamble/cJSON"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
7
8SRC_URI = "git://github.com/DaveGamble/cJSON.git"
9SRCREV = "39853e5148dad8dc5d32ea2b00943cf4a0c6f120"
10
11S = "${WORKDIR}/git"
12
13inherit cmake pkgconfig
14
15EXTRA_OECMAKE += "\
16 -DENABLE_CJSON_UTILS=On \
17 -DENABLE_CUSTOM_COMPILER_FLAGS=OFF \
18 -DBUILD_SHARED_AND_STATIC_LIBS=On \
19"
20
21BBCLASSEXTEND = "native nativesdk"