Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Bash Automated Testing System" |
| 2 | DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \ |
| 3 | provides a simple way to verify that the UNIX programs you write behave as expected." |
| 4 | AUTHOR = "Sam Stephenson & bats-core organization" |
| 5 | HOMEPAGE = "https://github.com/bats-core/bats-core" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" |
| 8 | |
| 9 | SRC_URI = "git://github.com/bats-core/bats-core.git \ |
| 10 | " |
| 11 | # v1.1.0 |
| 12 | SRCREV = "c706d1470dd1376687776bbe985ac22d09780327" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_install() { |
| 17 | # Just a bunch of bash scripts to install |
| 18 | ${S}/install.sh ${D}${prefix} |
| 19 | } |
| 20 | |
| 21 | RDEPENDS_bats = "bash" |