Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Python bindings for DBus AT-SPI2 accessibility" |
| 2 | DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca" |
| 3 | SECTION = "devel/python" |
| 4 | HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \ |
| 7 | file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe" |
| 8 | DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject" |
| 9 | |
| 10 | SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master" |
| 11 | SRCREV = "141a53029b3e16bfa5f100ae54a77234a9bf3426" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | # Same restriction as gtk+ |
| 16 | inherit features_check setuptools3 |
| 17 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
| 18 | |
| 19 | inherit pkgconfig autotools python3native |
| 20 | |
| 21 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*" |