Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 1 | SUMMARY = "A Python implementation of Recursive Length Prefix encoding (RLP)." |
| 2 | HOMEPAGE = "https://github.com/ethereum/pyrlp" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "63b0465d2948cd9f01de449d7adfb92d207c1aef3982f20310f8009be4a507e8" |
| 8 | SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | DEPENDS += "python3-pip-native" |
| 13 | |
| 14 | RDEPENDS:${PN} += "python3-eth-utils" |