Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Supervisor: A Process Control System" |
| 2 | DESCRIPTION = "\ |
| 3 | Supervisor is a client/server system that allows its users \ |
| 4 | to monitorand control a number of processes on UNIX-like \ |
| 5 | operating systems." |
| 6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" |
| 7 | LICENSE = "BSD-4-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "40dc582ce1eec631c3df79420b187a6da276bbd68a4ec0a8f1f123ea616b97a2" |
| 11 | |
| 12 | PYPI_PACKAGE = "supervisor" |
| 13 | inherit pypi systemd setuptools3 |
| 14 | RDEPENDS:${PN} = "\ |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame^] | 15 | python3-meld3 \ |
| 16 | python3-io \ |
| 17 | python3-xmlrpc \ |
| 18 | python3-resource \ |
| 19 | python3-setuptools \ |
| 20 | python3-smtpd \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | SRC_URI += "file://supervisord.conf \ |
| 24 | file://supervisor.service \ |
| 25 | " |
| 26 | SYSTEMD_SERVICE:${PN} = "supervisor.service" |
| 27 | |
| 28 | do_install:append() { |
| 29 | install -d ${D}${sysconfdir}/supervisor |
| 30 | install -d ${D}${systemd_system_unitdir} |
| 31 | |
| 32 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor |
| 33 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} |
| 34 | } |