Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Setuptools Rust extension plugin" |
| 2 | DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \ |
| 3 | Python extensions implemented with PyO3 or rust-cpython.\ |
| 4 | \ |
| 5 | Compile and distribute Python extensions written in Rust as easily as if they were written in C." |
| 6 | HOMEPAGE = "https://github.com/PyO3/setuptools-rust" |
| 7 | BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5" |
| 11 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame^] | 12 | SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \ |
| 13 | file://8e9892f08b1248dc03862da86915c2745e0ff7ec.patch" |
| 14 | SRC_URI[sha256sum] = "18ff850831f58ee21d5783825c99fad632da21e47645e9427fd7dec048029e76" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 16 | inherit cargo pypi python_setuptools_build_meta |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 17 | |
| 18 | DEPENDS += "python3-setuptools-scm-native python3-wheel-native" |
| 19 | |
| 20 | RDEPENDS:${PN}:class-native += " \ |
| 21 | python3-semantic-version-native \ |
| 22 | python3-setuptools-native \ |
| 23 | python3-setuptools-scm-native \ |
| 24 | python3-toml-native \ |
| 25 | python3-typing-extensions-native \ |
| 26 | python3-wheel-native \ |
| 27 | " |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "native" |