Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Tiny XML Library" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | HOMEPAGE = "https://www.msweet.org/mxml/" |
| 5 | BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues" |
| 6 | |
| 7 | SRC_URI = "git://github.com/michaelrsweet/mxml.git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | SRCREV = "c7755b6992a2afdd34dde47fc9be97f1237cfded" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | S = "${WORKDIR}/git" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | # v3.0 |
| 11 | PV = "3.0" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | CONFIGUREOPTS = " --prefix=${prefix} \ |
| 14 | --bindir=${bindir} \ |
| 15 | --sbindir=${sbindir} \ |
| 16 | --libexecdir=${libexecdir} \ |
| 17 | --datadir=${datadir} \ |
| 18 | --sysconfdir=${sysconfdir} \ |
| 19 | --sharedstatedir=${sharedstatedir} \ |
| 20 | --localstatedir=${localstatedir} \ |
| 21 | --libdir=${libdir} \ |
| 22 | --includedir=${includedir} \ |
| 23 | --oldincludedir=${oldincludedir} \ |
| 24 | --infodir=${infodir} \ |
| 25 | --mandir=${mandir} \ |
| 26 | --host=${TARGET_SYS} \ |
| 27 | --build=${BUILD_SYS} \ |
| 28 | ${PACKAGECONFIG_CONFARGS} \ |
| 29 | " |
| 30 | |
| 31 | do_configure() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 33 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | ./configure ${CONFIGUREOPTS} --enable-shared |
| 35 | } |
| 36 | |
| 37 | do_install () { |
| 38 | export DSTROOT=${D} |
| 39 | oe_runmake install |
| 40 | } |
| 41 | |
| 42 | PACKAGES += " ${PN}-bin " |
| 43 | FILES_${PN} = "${libdir}/*" |
| 44 | FILES_${PN}-bin = "${bindir}/*" |