Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 1 | SUMMARY = "High-level language, primarily intended for numerical computations" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/octave/" |
| 3 | SECTION = "math" |
| 4 | |
| 5 | LICENSE = "GPL-3.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 7 | |
| 8 | # To build, add 'FORTRAN:forcevariable = ",fortran"' to your local.conf (or use |
| 9 | # meta-mortsgna as distro :) |
| 10 | |
| 11 | DEPENDS = " \ |
| 12 | gperf-native \ |
| 13 | libglu \ |
| 14 | lapack \ |
| 15 | fftw \ |
| 16 | curl \ |
| 17 | freetype \ |
| 18 | fontconfig \ |
| 19 | texinfo \ |
| 20 | pcre \ |
| 21 | readline \ |
| 22 | fltk \ |
| 23 | hdf5 \ |
| 24 | libsndfile1 \ |
| 25 | " |
| 26 | |
| 27 | inherit autotools pkgconfig texinfo gettext gtk-icon-cache mime-xdg features_check |
| 28 | |
| 29 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 30 | |
| 31 | SRC_URI = " \ |
| 32 | ${GNU_MIRROR}/octave/${BPN}-${PV}.tar.gz \ |
| 33 | file://fix-blas-library-integer-size.patch \ |
| 34 | " |
| 35 | SRC_URI[sha256sum] = "b48f33d4fceaf394cfbea73a8c850000936d83a41739a24f7568b5b0a7b39acd" |
| 36 | |
| 37 | EXTRA_OECONF = " \ |
| 38 | --disable-java \ |
| 39 | --disable-docs \ |
| 40 | " |
| 41 | |
| 42 | do_compile:prepend() { |
| 43 | for folder in "liboctave/operators liboctave/numeric liboctave/array liboctave/util"; do |
| 44 | mkdir -p ${B}/${folder} |
| 45 | done |
| 46 | } |
| 47 | |
| 48 | FILES:${PN} += "${datadir}/metainfo" |
| 49 | FILES:${PN}-dev += "${libdir}/${BPN}/${PV}/lib*${SOLIBSDEV}" |
| 50 | |
| 51 | # fortran is not enabled by default |
| 52 | EXCLUDE_FROM_WORLD = "1" |