Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser)" |
| 2 | HOMEPAGE = "https://pypi.org/project/Arpeggio/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=33b8d1ba459a2fa4d801acfd1d1b7ceb" |
| 5 | |
| 6 | SRC_URI[md5sum] = "39667a626217c670bc634444be6e904a" |
| 7 | SRC_URI[sha256sum] = "948ce06163a48a72c97f4fe79ad3d1c1330b6fec4f22ece182fb60ef60bd022b" |
| 8 | |
| 9 | PYPI_PACKAGE = "Arpeggio" |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | # setup.py of Arpeggio needs this. |
| 13 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |