Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc." |
| 2 | HOMEPAGE = "https://github.com/aio-libs/multidict/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a" |
| 5 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | inherit pypi setuptools3 ptest |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 7 | |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 8 | SRC_URI[md5sum] = "22b46f759cf2cc3ca1d2c9f82cc9bb79" |
| 9 | SRC_URI[sha256sum] = "d7d428488c67b09b26928950a395e41cc72bb9c3d5abfe9f0521940ee4f796d4" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |