Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Intel gma500_gfx fix for certain hardware" |
| 2 | DESCRIPTION = "Avoid inserting gma500_gfx module for certain hardware devices." |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 5 | |
| 6 | SRC_URI = "file://gma500-gfx-check.conf \ |
| 7 | file://gma500-gfx-check.sh " |
| 8 | |
| 9 | do_install(){ |
| 10 | install -d ${D}${sysconfdir}/modprobe.d/ |
| 11 | install -m 755 ${WORKDIR}/gma500-gfx-check.sh ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.sh |
| 12 | install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf |
| 13 | } |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | FILES:${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 16 | ${sysconfdir}/modprobe.d/gma500-gfx-check.sh" |
| 17 | |
| 18 | COMPATIBLE_MACHINE = "genericx86" |