Jie Yang | 7fe1bad | 2021-08-06 12:41:16 -0700 | [diff] [blame] | 1 | SUMMARY = "GLOME Login Client" |
| 2 | DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines" |
| 3 | PR = "r1" |
| 4 | PV = "0.1+git${SRCPV}" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 8 | |
| 9 | inherit meson pkgconfig |
| 10 | |
| 11 | DEPENDS += " \ |
| 12 | openssl \ |
| 13 | glib-2.0 \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | SRC_URI = "git://github.com/google/glome.git" |
| 18 | SRCREV = "b7084b5c60682a0b4f4ae3f2ec6048e65212c377" |
| 19 | |
| 20 | FILES_${PN} += "${libdir}/security" |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false" |
| 24 | PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam" |
| 25 | |
| 26 | EXTRA_OEMESON = "-Dtests=disabled" |