Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager" |
| 2 | LICENSE = "GPL-3.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 4 | |
| 5 | DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" |
| 6 | |
| 7 | inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ |
| 11 | file://0001-Search-for-cython3.patch \ |
| 12 | file://0002-fix-fail-to-enable-bluetooth.patch \ |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame^] | 13 | file://0001-meson-add-pythoninstalldir-option.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | " |
| 15 | SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602" |
| 16 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame^] | 17 | EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false -Dpythoninstalldir=${@noprefix('PYTHON_SITEPACKAGES_DIR', d)}" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | |
| 19 | SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" |
| 20 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
| 21 | |
| 22 | RRECOMENDS_${PN} += "adwaita-icon-theme" |
| 23 | RDEPENDS:${PN} += " \ |
| 24 | python3-core \ |
| 25 | python3-dbus \ |
| 26 | python3-pygobject \ |
| 27 | python3-terminal \ |
| 28 | packagegroup-tools-bluetooth \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG ??= " \ |
| 32 | ${@bb.utils.filter('DISTRO_FEATURES', 'polkit pulseaudio ', d)} \ |
| 33 | thunar \ |
| 34 | " |
| 35 | PACKAGECONFIG[thunar] = "-Dthunar-sendto=true,-Dthunar-sendto=false" |
| 36 | PACKAGECONFIG[pulseaudio] = "-Dpulseaudio=true,-Dpulseaudio=false" |
| 37 | PACKAGECONFIG[polkit] = "-Dpolicykit=true,-Dpolicykit=false" |
| 38 | |
| 39 | FILES:${PN} += " \ |
| 40 | ${datadir} \ |
| 41 | ${systemd_user_unitdir} \ |
| 42 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 43 | " |
| 44 | |
| 45 | # In code, path to python is a variable that is replaced with path to native version of it |
| 46 | # during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3. |
| 47 | # Replace it with #!/usr/bin/env python3 |
| 48 | do_install:append() { |
| 49 | sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \ |
| 50 | ${D}${prefix}/libexec/blueman-mechanism \ |
| 51 | ${D}${bindir}/blueman-adapters \ |
| 52 | ${D}${bindir}/blueman-applet \ |
| 53 | ${D}${bindir}/blueman-manager \ |
| 54 | ${D}${bindir}/blueman-sendto \ |
| 55 | ${D}${bindir}/blueman-services \ |
| 56 | ${D}${bindir}/blueman-tray |
| 57 | } |
| 58 | |