Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Python bindings for DBus AT-SPI2 accessibility" |
| 2 | DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca" |
| 3 | SECTION = "devel/python" |
| 4 | HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886 \ |
| 7 | file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe" |
| 8 | DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject" |
| 9 | |
| 10 | SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=gnome-3-32" |
| 11 | SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d" |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 14 | # Same restriction as gtk+ |
| 15 | inherit distro_features_check |
| 16 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
| 17 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 18 | inherit pkgconfig autotools python3native |
| 19 | |
| 20 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*" |