Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \ |
| 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \ |
| 8 | " |
| 9 | |
| 10 | inherit module |
| 11 | |
| 12 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux' |
| 13 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 15 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 16 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| 17 | " |
| 18 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 19 | SRC_URI[md5sum] = "07c0b1ea4c1dd9d3edba8dc980fd93dd" |
| 20 | SRC_URI[sha256sum] = "e0d031005eef337c62de530a3b5b3e8fb1c732846eefcb23b8978edd2091f6e4" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | |
| 22 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 23 | |
| 24 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 25 | |
| 26 | do_install_append() { |
| 27 | # Delete empty directories to avoid QA failures if no modules were built |
| 28 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 29 | } |
| 30 | |
| 31 | python do_package_prepend() { |
| 32 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 33 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 34 | } |
| 35 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 36 | BBCLASSEXTEND = "devupstream:target" |
| 37 | LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3" |
| 38 | DEFAULT_PREFERENCE_class-devupstream = "-1" |
| 39 | SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.10 \ |
| 40 | file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| 41 | file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| 42 | " |
| 43 | SRCREV_class-devupstream = "624aca5d7507fbd11ea4a1a474c3aa1031bd9a31" |
| 44 | PV_class-devupstream = "2.10.10+git${SRCPV}" |
| 45 | S_class-devupstream = "${WORKDIR}/git" |