Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b" |
| 5 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "ac21b1e21dc6fdfee9a57b53f4777539d53a84f2e1546a3f802f159f9966bdc1" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | |
| 12 | inherit pypi setuptools3 ptest |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | ${PYTHON_PN}-pytest \ |
| 16 | " |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | install -d ${D}${PTEST_PATH}/tests |
| 20 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 21 | } |