Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | Upstream-Status: Inappropriate [debian patch] |
| 2 | |
| 3 | Signed-Off-by: Nitin A Kamble <nitin.a.kamble@intel.com> |
| 4 | |
| 5 | From 848543091d55dddb54a85612155964506d712852 Mon Sep 17 00:00:00 2001 |
| 6 | From: Rob Browning <rlb@defaultvalue.org> |
| 7 | Date: Sun, 18 Mar 2012 13:28:24 -0500 |
| 8 | Subject: Mark "mutex with owner not retained" threads test as unresolved. |
| 9 | |
| 10 | As per discussion with upstream, mark this test as unresolved since it |
| 11 | may produce false negatives, depending on the behavior/timing of the |
| 12 | garbage collector. |
| 13 | --- |
| 14 | test-suite/tests/threads.test | 6 ++++-- |
| 15 | 1 files changed, 4 insertions(+), 2 deletions(-) |
| 16 | |
| 17 | diff --git a/test-suite/tests/threads.test b/test-suite/tests/threads.test |
| 18 | index 85a7c38..50899cb 100644 |
| 19 | --- a/test-suite/tests/threads.test |
| 20 | +++ b/test-suite/tests/threads.test |
| 21 | @@ -414,8 +414,10 @@ |
| 22 | |
| 23 | (gc) (gc) |
| 24 | (let ((m (g))) |
| 25 | - (and (mutex? m) |
| 26 | - (eq? (mutex-owner m) (current-thread))))))) |
| 27 | + (or |
| 28 | + (and (mutex? m) |
| 29 | + (eq? (mutex-owner m) (current-thread))) |
| 30 | + (throw 'unresolved)))))) |
| 31 | |
| 32 | ;; |
| 33 | ;; mutex lock levels |