Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An SGML parser" |
| 2 | DESCRIPTION = "An SGML parser used by the OpenJade suite of utilities." |
| 3 | HOMEPAGE = "http://openjade.sourceforge.net" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045" |
| 7 | |
| 8 | PR = "r1" |
| 9 | |
| 10 | # At -Os it encounters calls to some inline functions which are then |
| 11 | # not found in any other objects with gcc 4.5 |
| 12 | FULL_OPTIMIZATION += "-O2" |
| 13 | |
| 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \ |
| 15 | file://obsolete_automake_macros.patch \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "670b223c5d12cee40c9137be86b6c39b" |
| 19 | SRC_URI[sha256sum] = "57f4898498a368918b0d49c826aa434bb5b703d2c3b169beb348016ab25617ce" |
| 20 | |
| 21 | S = "${WORKDIR}/OpenSP-${PV}" |
| 22 | |
| 23 | inherit autotools gettext |
| 24 | |
| 25 | EXTRA_OECONF = "--disable-doc-build" |
| 26 | |
| 27 | EXTRA_OECONF_class-native = "\ |
| 28 | --disable-doc-build \ |
| 29 | --enable-default-catalog=${sysconfdir}/sgml/catalog \ |
| 30 | --enable-default-search-path=${datadir}/sgml \ |
| 31 | " |
| 32 | |
| 33 | do_install_append() { |
| 34 | # Set up symlinks to often-used alternate names. See |
| 35 | # http://www.linuxfromscratch.org/blfs/view/stable/pst/opensp.html |
| 36 | cd ${D}${libdir} |
| 37 | ln -sf libosp.so libsp.so |
| 38 | |
| 39 | cd ${D}${bindir} |
| 40 | for util in nsgmls sgmlnorm spam spcat spent sx; do |
| 41 | ln -sf o$util $util |
| 42 | done |
| 43 | ln -sf osx sgml2xml |
| 44 | } |
| 45 | |
| 46 | do_install_append_class-native() { |
| 47 | for util in nsgmls sgmlnorm spam spcat spent sx; do |
| 48 | create_cmdline_wrapper ${D}/${bindir}/$util \ |
| 49 | -D ${sysconfdir}/sgml |
| 50 | done |
| 51 | } |
| 52 | |
| 53 | FILES_${PN} += "${datadir}/OpenSP/" |
| 54 | |
| 55 | BBCLASSEXTEND = "native" |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 56 | |
| 57 | # http://errors.yoctoproject.org/Errors/Details/20489/ |
| 58 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 59 | ARM_INSTRUCTION_SET_armv5 = "arm" |