Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Security-focused ELF files checking tool" |
| 2 | DESCRIPTION = "This is a small set of various PaX aware and related \ |
| 3 | utilities for ELF binaries. It can check ELF binary files and running \ |
| 4 | processes for issues that might be relevant when using ELF binaries \ |
| 5 | along with PaX, such as non-PIC code or executable stack and heap." |
| 6 | HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml" |
| 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 9 | |
| 10 | SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "bc3614322eaf88f167a608ae85d6b207" |
| 14 | SRC_URI[sha256sum] = "2945b3e4df2e0dc95800bfbd3d88ab2243b2ee4ff064bbfc75734f6d9d986a89" |
| 15 | |
| 16 | RDEPENDS_${PN} += "bash" |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README |
| 20 | } |
| 21 | |
| 22 | do_install() { |
| 23 | oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native" |
| 27 | |
| 28 | inherit autotools pkgconfig |
| 29 | |
| 30 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \ |
| 31 | " |
| 32 | PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap" |
| 33 | PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp" |
| 34 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 35 | PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools" |