Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require python-setuptools.inc |
| 2 | |
| 3 | PROVIDES = "python-distribute" |
| 4 | |
| 5 | DEPENDS += "python" |
| 6 | DEPENDS_class-native += "python-native" |
| 7 | |
| 8 | inherit distutils |
| 9 | |
| 10 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" |
| 11 | |
| 12 | RDEPENDS_${PN} = "\ |
| 13 | python-stringold \ |
| 14 | python-email \ |
| 15 | python-shell \ |
| 16 | python-distutils \ |
| 17 | python-compression \ |
| 18 | python-pkgutil \ |
| 19 | python-plistlib \ |
| 20 | python-numbers \ |
| 21 | python-html \ |
| 22 | python-netserver \ |
| 23 | python-ctypes \ |
| 24 | python-subprocess \ |
| 25 | python-unittest \ |
| 26 | python-compile \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS_${PN}_class-native = "\ |
| 30 | python-distutils \ |
| 31 | python-compression \ |
| 32 | " |
| 33 | |
| 34 | RREPLACES_${PN} = "python-distribute" |
| 35 | RPROVIDES_${PN} = "python-distribute" |
| 36 | RCONFLICTS_${PN} = "python-distribute" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |