Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets" |
| 2 | LICENSE = "LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6" |
| 4 | |
| 5 | inherit gnomebase gtk-doc vala gobject-introspection |
| 6 | |
| 7 | DEPENDS += "glib-2.0 libgcrypt gettext-native intltool-native" |
| 8 | |
| 9 | EXTRA_OECONF += "--disable-manpages" |
| 10 | |
| 11 | SRC_URI[archive.md5sum] = "5190da1ee686437046bc10068f120d1d" |
| 12 | SRC_URI[archive.sha256sum] = "0f29b51698198e6999c91f4adce3119c8c457f546b133a85baea5ea9010a19ed" |
| 13 | |
| 14 | # http://errors.yoctoproject.org/Errors/Details/20228/ |
| 15 | ARM_INSTRUCTION_SET = "arm" |
| 16 | |
| 17 | # vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes |
| 18 | do_configure_prepend() { |
| 19 | rm -f ${S}/build/m4/vapigen.m4 |
| 20 | } |
| 21 | |
| 22 | # Secret-1: poky/build-mips64/tmp/work/mips64-poky-linux/libgpg-error/1.19-r0/libgpg-error-1.19/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed. |
| 23 | # qemu: uncaught target signal 6 (Aborted) - core dumped |
| 24 | EXTRA_OECONF_append_mips64 = " --disable-introspection" |
| 25 | |