Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenGL driver testing framework" |
| 2 | LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0" |
| 4 | |
| 5 | SRC_URI = "git://anongit.freedesktop.org/piglit \ |
| 6 | file://0001-tests-Fix-missing-include-of-Xutil.h.patch" |
| 7 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 8 | # From 2015-02-19 |
| 9 | SRCREV = "c4585427913e4cb28994b4bfb11d49778273aa2c" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | # (when PV goes above 1.0 remove the trailing r) |
| 11 | PV = "1.0+gitr${SRCPV}" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | DEPENDS = "virtual/libx11 libxrender waffle virtual/libgl libglu python-mako-native python-numpy-native" |
| 16 | |
| 17 | inherit cmake pythonnative distro_features_check |
| 18 | # depends on virtual/libx11 |
| 19 | REQUIRED_DISTRO_FEATURES = "x11" |
| 20 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 21 | # The built scripts go into the temporary directory according to tempfile |
| 22 | # (typically /tmp) which can race if multiple builds happen on the same machine, |
| 23 | # so tell it to use a directory in ${B} to avoid overwriting. |
| 24 | export TEMP = "${B}/temp/" |
| 25 | do_compile[dirs] =+ "${B}/temp/" |
| 26 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | PACKAGECONFIG ??= "" |
| 28 | PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut," |
| 29 | |
| 30 | do_configure_prepend() { |
| 31 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then |
| 32 | sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h |
| 33 | sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h |
| 34 | fi |
| 35 | } |
| 36 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 38 | python-argparse python-importlib python-unixadmin python-xml \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | python-multiprocessing python-textutils python-netserver python-shell \ |
| 40 | mesa-demos bash \ |
| 41 | " |
| 42 | |
| 43 | INSANE_SKIP_${PN} += "dev-so" |