Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV', True).split('.')[0]}.${@d.getVar('PV', True).split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "e4757d09012ed93822b1ee41435fec24" |
| 15 | SRC_URI[sha256sum] = "db55628b5c7d952945bb71b236469057c8dfb8dea0c271513579c6273c2093dc" |
| 16 | |
| 17 | S = "${WORKDIR}/libsoup-${PV}" |
| 18 | |
| 19 | inherit autotools gettext pkgconfig upstream-version-is-even gobject-introspection |
| 20 | |
| 21 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome" |
| 24 | |
| 25 | EXTRA_OECONF = "--disable-vala" |
| 26 | |
| 27 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 28 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 29 | # renaming in order to keep the package name consistent regardless of whether |
| 30 | # gnome support is enabled or disabled. |
| 31 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 32 | |
| 33 | # glib-networking is needed for SSL, proxies, etc. |
| 34 | RRECOMMENDS_${PN} = "glib-networking" |