Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "An asynchronous event notification library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A software library that provides asynchronous event \ |
| 3 | notification. The libevent API provides a mechanism to execute a callback \ |
| 4 | function when a specific event occurs on a file descriptor or after a \ |
| 5 | timeout has been reached. libevent also supports callbacks triggered \ |
| 6 | by signals and regular timeouts" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | HOMEPAGE = "http://libevent.org/" |
| 8 | BUGTRACKER = "https://github.com/libevent/libevent/issues" |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | LICENSE = "BSD & MIT" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549" |
| 13 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \ |
| 15 | file://Makefile-missing-test-dir.patch \ |
| 16 | file://run-ptest \ |
| 17 | file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 18 | file://0002-test-regress.h-Increase-default-timeval-tolerance-50.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 21 | SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | |
| 23 | UPSTREAM_CHECK_URI = "http://libevent.org/" |
| 24 | |
| 25 | S = "${WORKDIR}/${BPN}-${PV}-stable" |
| 26 | |
| 27 | PACKAGECONFIG ??= "" |
| 28 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 29 | |
| 30 | inherit autotools |
| 31 | |
| 32 | # Needed for Debian packaging |
| 33 | LEAD_SONAME = "libevent-2.1.so" |
| 34 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | inherit ptest multilib_header |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 36 | |
| 37 | DEPENDS = "zlib" |
| 38 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 39 | PACKAGES_DYNAMIC = "^${PN}-.*$" |
| 40 | python split_libevent_libs () { |
| 41 | do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True) |
| 42 | } |
| 43 | PACKAGESPLITFUNCS_prepend = "split_libevent_libs " |
| 44 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 45 | BBCLASSEXTEND = "native nativesdk" |
| 46 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | do_install_append() { |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 48 | rm ${D}${bindir}/event_rpcgen.py |
| 49 | rmdir ${D}${bindir} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 50 | oe_multilib_header event2/event-config.h |
| 51 | } |
| 52 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 53 | do_install_ptest() { |
| 54 | install -d ${D}${PTEST_PATH}/test |
| 55 | for file in ${B}/test/.libs/regress ${B}/test/.libs/test* |
| 56 | do |
| 57 | install -m 0755 $file ${D}${PTEST_PATH}/test |
| 58 | done |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 59 | |
| 60 | # handle multilib |
| 61 | sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | } |