blob: 58342b6c2211548d7065a49ff06503eeab33ffde [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Javascript bindings for GNOME"
2LICENSE = "MIT & LGPLv2+"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
5 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
6"
7
8GNOMEBASEBUILDCLASS = "autotools"
9
10DEPENDS = "mozjs gtk+3"
11
12inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
13
Andrew Geisslere231d582020-05-05 08:53:09 -050014SRC_URI[archive.md5sum] = "c8c530d4593133f496ae69098273a675"
15SRC_URI[archive.sha256sum] = "2014509019ea4e7a8ab8e0dd0c472bbcf0ad3067928af88c29f5e2879c58c7a9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016SRC_URI += "file://0001-Disable-tests-on-host.patch"
17
18# gobject-introspection is mandatory and cannot be configured
19REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
20UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
21
22EXTRA_OECONF = " \
23 --without-dbus-tests \
24 --disable-installed-tests \
25"
26
27do_configure_prepend() {
28 # make configure find gobject-introspection test code. Although we set
29 # --disable-installed-tests gjs builds them
30 sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
31}
32
33FILES_${PN} += "${datadir}/gjs-1.0/lsan"
34
35PACKAGES =+ "${PN}-valgrind"
36FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
37RSEPENDS_${PN}-valgrind += "valgrind"