blob: 8ace29ed18f98160623b3ed5c0ce088603b0cf12 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "pytest plugin for generating html reports from test results"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-html"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://../pytest-html.LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
5
6# Per README.rst the license statement is fetched from
7# https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE
8SRC_URI += "https://raw.githubusercontent.com/davehunt/pytest-html/master/LICENSE;name=license;downloadfilename=pytest-html.LICENSE"
9
10PYPI_PACKAGE = "pytest-html"
11
12inherit pypi setuptools3
13
14SRC_URI[md5sum] = "ac956864a9b3392203dacd287ae450f0"
15SRC_URI[sha256sum] = "a359de04273239587bd1a15b29b2266daeaf56b7a13f8224bc4fb3ae0ba72c3f"
16SRC_URI[license.md5sum] = "5d425c8f3157dbf212db2ec53d9e5132"
17SRC_URI[license.sha256sum] = "2bfdca60adf803108d4c7f009000bea76ad00e621e163197881b0eaae91b530e"
18
19RDEPENDS_${PN} = "${PYTHON_PN}-pytest"