Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Video Acceleration (VA) API for Linux" |
| 2 | DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \ |
| 3 | and API specification which enables and provides access to graphics \ |
| 4 | hardware (GPU) acceleration for video processing on Linux and UNIX \ |
| 5 | based operating systems. Accelerated processing includes video \ |
| 6 | decoding, video encoding, subpicture blending and rendering. The \ |
| 7 | specification was originally designed by Intel for its GMA (Graphics \ |
| 8 | Media Accelerator) series of GPU hardware, the API is however not \ |
| 9 | limited to GPUs or Intel specific hardware, as other hardware and \ |
| 10 | manufacturers can also freely use this API for hardware accelerated \ |
| 11 | video decoding." |
| 12 | |
| 13 | HOMEPAGE = "https://01.org/linuxmedia/vaapi" |
| 14 | BUGTRACKER = "https://github.com/intel/libva/issues" |
| 15 | |
| 16 | SECTION = "x11" |
| 17 | LICENSE = "MIT" |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" |
| 19 | |
| 20 | SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2" |
| 21 | SRC_URI[md5sum] = "aef13eb48e01a47d1416d97462a22a11" |
| 22 | SRC_URI[sha256sum] = "6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e48629401eaea5" |
| 23 | |
| 24 | UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases" |
| 25 | |
| 26 | DEPENDS = "libdrm virtual/mesa" |
| 27 | |
| 28 | inherit meson pkgconfig features_check |
| 29 | |
| 30 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 31 | |
| 32 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 33 | PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes" |
| 34 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland" |
| 35 | |
| 36 | PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" |
| 37 | |
| 38 | RDEPENDS_${PN}-x11 =+ "${PN}" |
| 39 | RDEPENDS_${PN}-glx =+ "${PN}-x11" |
| 40 | |
| 41 | FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" |
| 42 | FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" |
| 43 | FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" |