Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 3 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | |
| 6 | SRCREV = "9608fa3bcf8020d35f59fbf70cd3cbe4b015b972" |
| 7 | SRC_URI = "git://github.com/gperftools/gperftools \ |
| 8 | file://0001-Support-Atomic-ops-on-clang.patch \ |
| 9 | file://0001-fix-build-with-musl-libc.patch \ |
| 10 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 11 | file://disable_libunwind_aarch64.patch \ |
| 12 | file://sgidef.patch \ |
| 13 | " |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | # On mips, we have the following error. |
| 20 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
| 21 | # Segmentation fault (core dumped) |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 22 | COMPATIBLE_HOST_mipsarch = "null" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | # Disable thumb1 |
| 24 | # {standard input}: Assembler messages: |
| 25 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 26 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
| 27 | ARM_INSTRUCTION_SET_armv5 = "arm" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 30 | PACKAGECONFIG ?= "libunwind static" |
| 31 | PACKAGECONFIG_remove_arm_libc-musl = "libunwind" |
| 32 | |
| 33 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
| 34 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 35 | |
| 36 | PACKAGE_BEFORE_PN += "libtcmalloc-minimal" |
| 37 | FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 38 | |
| 39 | # pprof tool requires Getopt::long and POSIX perl5 modules. |
| 40 | # Also runs `objdump` on each cpuprofile data file |
| 41 | RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix" |
| 42 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 43 | RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})" |
| 44 | |