Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require go-${PV}.inc |
2 | require go-target.inc | ||||
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 3 | |
4 | export GOBUILDMODE="" | ||||
5 | |||||
6 | # Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips | ||||
7 | # doesn't support -buildmode=pie, so skip the QA checking for mips and its | ||||
8 | # variants. | ||||
9 | python() { | ||||
10 | if 'mips' in d.getVar('TARGET_ARCH'): | ||||
11 | d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel") | ||||
12 | else: | ||||
13 | d.setVar('GOBUILDMODE', 'pie') | ||||
14 | } |