Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Flex (The Fast Lexical Analyzer)" |
| 2 | DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \ |
| 3 | lexical patterns in text." |
| 4 | HOMEPAGE = "http://sourceforge.net/projects/flex/" |
| 5 | SECTION = "devel" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | |
| 8 | DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}" |
| 9 | BBCLASSEXTEND = "native nativesdk" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067" |
| 12 | |
| 13 | SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \ |
| 14 | file://run-ptest \ |
| 15 | file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \ |
| 16 | ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \ |
| 17 | file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \ |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 18 | file://check-funcs.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d" |
| 22 | SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995" |
| 23 | |
| 24 | # Flex has moved to github from 2.6.1 onwards |
| 25 | UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases" |
| 26 | UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar" |
| 27 | |
| 28 | inherit autotools gettext texinfo ptest |
| 29 | |
| 30 | M4 = "${bindir}/m4" |
| 31 | M4_class-native = "${STAGING_BINDIR_NATIVE}/m4" |
| 32 | EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no" |
| 33 | EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4" |
| 34 | |
| 35 | EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}" |
| 36 | |
| 37 | do_install_append_class-native() { |
| 38 | create_wrapper ${D}/${bindir}/flex M4=${M4} |
| 39 | } |
| 40 | |
| 41 | do_install_append_class-nativesdk() { |
| 42 | create_wrapper ${D}/${bindir}/flex M4=${M4} |
| 43 | } |
| 44 | |
| 45 | PACKAGES =+ "${PN}-libfl" |
| 46 | |
| 47 | FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*" |
| 48 | |
| 49 | RDEPENDS_${PN} += "m4" |
| 50 | RDEPENDS_${PN}-ptest += "bash gawk make" |
| 51 | |
| 52 | do_compile_ptest() { |
| 53 | oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests |
| 54 | } |
| 55 | |
| 56 | do_install_ptest() { |
| 57 | mkdir -p ${D}${PTEST_PATH}/build-aux/ |
| 58 | cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ |
| 59 | cp -r ${S}/tests/* ${D}${PTEST_PATH} |
| 60 | cp -r ${B}/tests/* ${D}${PTEST_PATH} |
| 61 | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 62 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 63 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 64 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 65 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \ |
| 66 | -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \ |
| 67 | -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \ |
| 68 | -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \ |
| 69 | -i ${D}${PTEST_PATH}/Makefile |
| 70 | } |
| 71 | # The uninative loader is different on i386 & x86_64 hosts. Since it is only |
| 72 | # being replaced with /bin/false anyway, it doesn't need to be part of the task |
| 73 | # hash |
| 74 | do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER" |
| 75 | |
| 76 | # Not Apache Flex, or Adobe Flex, or IBM Flex. |
| 77 | CVE_PRODUCT = "flex_project:flex" |