Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Dependency management tool for Golang" |
| 2 | HOMEPAGE = "https://github.com/golang/dep" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" |
| 5 | |
| 6 | GO_IMPORT = "github.com/golang/dep" |
| 7 | SRC_URI = "git://${GO_IMPORT} \ |
| 8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | file://0001-bolt_riscv64-Add-support-for-riscv64.patch;patchdir=src/github.com/golang/dep \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | " |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 11 | SRC_URI_append_riscv64 = " file://0001-Update-sys-module-to-latest.patch;patchdir=src/github.com/golang/dep " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 13 | SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | inherit go |
| 16 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 17 | # New Go versions has Go modules support enabled by default and cause the Glide |
| 18 | # tool build to fail. |
| 19 | export GO111MODULE = "off" |
| 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" |
| 22 | |
| 23 | RDEPENDS_${PN}-dev += "bash" |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |
| 26 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | # For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain. |
| 28 | # error message: vet config not found |
| 29 | PTEST_ENABLED_mips = "0" |
| 30 | PTEST_ENABLED_mips64 = "0" |